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Experiment-0 

 

Laboratory Preliminaries and Data Acquisition Using LabVIEW 

 

Introduction The objectives of the first part of this experiment are to introduce the 

laboratory transformer and to show how to operate the oscilloscope as a curve 

tracer, displaying either a voltage transfer curve (VTC) or a current-voltage (I-

V) characteristic.  Other procedures are designed to better acquaint you with 

the test equipment in the laboratory.   

 

 The objectives of the second part of this experiment are to become acquainted 

with using computer-conrolled instrumentation for data acquisition.  

LabVIEW, a program developed by National Instruments, is the industry 

standard for programming computer-controlled instruments, and it will be 

used in this experiment as well as others to measure and record sensor 

readings and to characterize various electrical systems and devices.   

 

 LabVIEW is a graphical programming environment.  Unlike C/C++ where 

programs are written in text, LabVIEW creates Virtual Instruments (VIs) by 

graphically composing them from different elements and structures that are 

placed like the blocks of a block diagram and interconnect with wires to 

indicate the intended signal flow paths.  This is referred to as “G-code” for the 

graphical language that it uses.  The most important aspect of understanding 

LabVIEW virtual instruments (VIs) is that they are data-driven, meaning that 

the execution of the block diagram procedes along the same path as which the 

data propagates through the block diagram.  A new block is not executed until 

the new data arrives at its input.  This is quite different from the event-driven 

programming of Windows, or the more familiar procedure-driven 

programming of FORTRAN, Pascal, or C/C++.  A complete tutorial for 

programming in LabVIEW will not be presented in this laboratory handbook 

since other excellent references exist for this purpose.   

 

 This experiment will introduce opening and running virtual instruments in 

LabVIEW and using it to control a data acquisition (DAQ) hardware for 

making electrical measurements.  In addition, some simple modifications to 

the virtual instruments will be performed to gain some experience with using 

the LabVIEW graphical interface and programming language.  These basic 

operation skills will be useful starting points for developing more complex 

data acquisition instruments in later experiments, and will form the basis for 

automated measurement of semiconductor device characteristics.  One of the 

important advantages of computer-based instruments is that recording 

measurement data becomes very easy, and some of this will be introduced in 

this experiment also.   
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Precautions Procedure 2 in this experiment requires you to run a resistor far above its rated 

power limit.  This will cause the resistor to heat up excessively and the danger 

to the operator is a thermal burn.  Please handle the resistor in this section 

with caution, allowing it to cool after use before it is handled.   
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Procedure 1 Transformer voltages 

 

Comment The two outputs of the lab transformer are nominally rated at 6.3 VAC, rms 

with respect to the neutral terminal.  This value of output voltage applies when 

the output current is at its full rated value of 2.0 Amps.  In an unloaded 

condition the output voltage is closer to 7.5 VAC, rms (a 10.6 V amplitude 

sinusoid) with respect to the neutral terminal.  Because the two outputs are 

rated 6.3 VAC, rms with respect to the common neutral terminal, they are 

also rated at 12.6 VAC, rms with respect to each other with a 2.0 Amp load 

current.  They produce 15.0 VAC, rms (a 21.2 V amplitude sinusoid) in an 

unloaded condition.  Your measured voltages may be a little different from 

these.   

 

Set-Up For this procedure you only need the laboratory transformer, the oscilloscope, 

a DC power supply, and some hook-up leads.  When you perform this 

procedure, connect both the common terminal of the DC supply and the 

oscilloscope ground lead to the lab transformer ground terminal (green) and 

connect the power supply output to the appropriate lab transformer output.  Be 

very careful to maintain only one ground point in your circuit!  Vary the DC 

output voltage to get the desired offset voltages.  If your sine wave does not 

have the specified amplitude, then adjust the offset voltages.   
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Figure E0.1  

 

Measurement-1 Display (and printout) on the screen of your oscilloscope the following output 

sinusoids from the lab transformer:   

 - A 10.6 V amplitude sinusoid with a –10.6 V offset voltage 

 - A 10.6 V amplitude sinusoid with a 0.0 V offset voltage 

 - A 21.2 V amplitude sinusoid with a 0.0 V offset voltage 

 - A 21.2 V amplitude sinusoid with a +21.2 V offset voltage 
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 To do this, set the center line of the oscilloscope display so that it corresponds 

to zero volts and set the oscilloscope coupling to DC.  As with all required 

oscilloscope printouts in this course, paste, tape, or staple the printout into 

your lab notebook and include any important information about the situation 

(instrument settings, etc.) under which the data was taken.   

 

Comment Because the input is DC coupled to the oscilloscope, the only way to produce 

these waveforms is by connecting the power supply to the appropriate output 

terminal.  This sets the terminal to the DC voltage output by the supply.  You 

can do this because the three lab transformer output terminals have a fixed 

voltage relative to each other, but no fixed voltage relative to ground; there is 

no connection between any of the secondary windings and anything else 

except via the flux linkages to the primary of the transformer.  When one of 

the secondary outputs is set to a DC value, the other voltages remain at their 

relative potentials, shifting up or down to accommodate the one fixed 

potential.   

 

Question-1 (a)  In producing the above waveforms, how much DC current flows through 

the ground connection (the green binding post) when it is connected to the DC 

power supply?  You should be able to deduce what this current is; however, 

you can also measure it with an ammeter.  Explain why the current is what it 

is.   

 (b)  How pure is the power line sinusoid?  Describe any deviations that you 

see.   
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Procedure 2 Internal resistance of the lab transformer 

 

Comment This procedure will dissipate more power in the 100  load resistor than its 

rated value of 1/4 W, resulting in a very hot resistor.  It is possible that the 

resistor may get hot enough to burn your fingers should you try to handle it 

while it is connected to the power supply (or immediately after the current 

through the resistor has been turned off).  When performing this procedure, 

use the solderless breadboard to hold the resistor and control the current 

through the resistor via the lab transformer power switch.  Try to minimize the 

time that the current flows through the resistor in order to minimize its 

heating.   

 

Set-Up For this procedure you will use the lab transformer and a 100 , 1/4 W 

resistor from your lab kit.  Disconnect all wires from the outputs of the lab 

transformer, turn it off and plug it into a 120 VAC receptacle.   

 

Figure E0.2 
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Measurement-2 Use the red and black output terminals of the lab transformer to produce the 

largest possible sinusoid.  With no load present, turn on the transformer and 

measure precisely the rms output voltage of the lab transformer with a DMM 

(set to AC volts) and record this value in your notebook.   

 

 Turn off the transformer and connect the selected outputs to a 100  resistor 

mounted on the breadboard (see Fig. E0.2).  Connect the DMM across the 

resistor and configure the DMM to read AC volts, turn on the power and read 

the voltage across the resistor.  Turn off the power immediately after the 

measurement in concluded and record the value of the voltage across the 

resistor in your lab notebook.    

 

Question-2 (a)  Assuming that the load resistor does not change its resistance when it 

heats up (it does somewhat), how much power is dissipated in the resistor?   



 Experiment-0 

R. B. Darling EE-331 Laboratory Handbook Page E0.6 

 (b)  Using the data that you have taken, what is the effective source resistance 

of the lab transformer when it is configured to output its largest voltage?   

 (c)  What is the smallest 1/4 W resistor in your lab kit that can be hooked up 

to the lab transformer between the red and black terminals without exceeding 

the resistor’s power rating?   
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Procedure 3 Create a curve tracer with your oscilloscope! 

 

Comment In this procedure you will use a standard oscilloscope and the laboratory 

transformer to display the current-voltage (I-V) characteristics of two 

components:  a diode and a resistor.  This procedure relies upon the ability to 

float the transformer output at a potential which is different from the ground 

of the oscilloscope.   

 

Set-Up Connect the circuit as shown in Fig. E0.3 using the following components 

  R1 = 1 k 1% 1/4 W resistor 

  DUT (Device Under Test) = 1 k 1% 1/4W resistor or a 1N4007 diode 

 

 Connect up only one component as the DUT at any time.  For the diode, note 

that the banded end is the cathode which corresponds to the bar end on the 

circuit symbol.  When a diode is used as the DUT, connect its cathode end to 

R1.   

 

Figure E0.3 
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Measurement-3 Turn the lab transformer power switch off and plug it into a 120 VAC 

receptacle.  Connect one lead from the black terminal (+6.3 VAC) of the lab 

transformer to the DUT (select the 1N4007 diode first) and then connect 

another lead from the red terminal (6.3 VAC) of the lab transformer to the 

resistor R1 on the breadboard as indicated in Fig. E0.3.  This will establish a 

21.2 V amplitude, 60 Hz sinusoidal input to the circuit.   

 

 Next, configure the oscilloscope to display the I-V curve as follows.  Attach 

the channel-1 oscilloscope probe to the DUT (at the same end as the power 

connection) and connect its ground lead to the point between the DUT and the 

resistor.  Attach the channel-2 oscilloscope probe to the resistor R1 (at the 

same end as the power connection) and also connect its ground lead to the 

point between the DUT and the resistor.  Configure the oscilloscope for an X-
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Y display and invert the signal on channel-2.  Make sure that the DUT voltage 

appears as the X-axis and the resistor R1 voltage as the Y-axis.  Since the 

voltage across the resistor is linearly proportional to the current through it and 

the DUT, the vertical (Y) axis also represents the diode current with a scaling 

factor of 1 Volt per milliamp.   

 

 Turn on the transformer and display the DUT I-V characteristic on the 

oscilloscope.  Make sure that the oscilloscope coupling to each channel is set 

to DC.  Calibrate the curve by aligning the displayed I-V characteristic to the 

origin of the screen display.  Sketch a copy of the I-V characteristic in your 

notebook using 1 V/div for the X-axis and 1 mA/div for the Y-axis.  Record 

any extra information that you think may be important.   

 

 Repeat this procedure for the resistor.   

 

Question-3 Which of the above DUTs is a linear circuit element?     
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Procedure 4 Oscilloscope input resistance 

 

Comment All voltage measurement devices, such as the DMM and oscilloscope, draw 

some current from the circuit to which they are connected.  For a high quality 

instrument, the key is to minimize this current so that the voltmeter affects the 

circuit as little as possible.  In this procedure the input resistance of the 

oscilloscope and its probes will be measured.   

 

Set-Up For this procedure you will need the following component 

  R1 = 10 M 5% 1/4W resistor 

 which is connected as shown in Fig. E0.4.  

 

Figure E0.4 
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Measurement-4 Set both channels on the oscilloscope to DC coupling and to either 5 or 2 V 

per division.  Using simple 1X probes, record the voltages as measured by 

each channel.  You can read the voltage off the display or use one of the 

options from the measurement menu of the oscilloscope.  Repeat the 

measurements using 10X probes for the oscilloscope.   

 

Question-4 Using the data you recorded and the fact that the internal resistance of the 

laboratory transformer is quite small compared to the 10 M resistor, 

calculate the input resistance of the oscilloscope with a 1X and with a 10X 

probe, assuming that both channels have the same input resistance.   

 



 Experiment-0 

R. B. Darling EE-331 Laboratory Handbook Page E0.10 

Procedure 5 When is a wire not a wire? 

 

Comment A common frustration is that the components indicated in text books and in 

schematics represent ideal elements, and yet there are no such things as ideal 

resistors, inductors, or capacitors.  Every real component has at least a little of 

each!  The purpose of this procedure is to illustrate a situation where two 

common components behave quite differently from their ideal forms.   

 

Set-Up For this procedure you will need the following components: 

  R1 = 100  5% 1/4 W resistor 

  R2 = an 8 inch length of hook-up wire 

  C1 = 10 F electrolytic capacitor. 

 These components are to be connected as shown in Fig. E0.5.   
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Figure E0.5  

 

Measurement-5 Configure the function generator to output a 5.0 V amplitude, 10 MHz 

sinewave.  Construct the circuit on your breadboard as shown above, 

connecting both channel-1 (VA) and channel-2 (VB) to the leads of resistor R1.  

Be sure to use only one piece of hook-up wire and to connect the ground of the 

function generator and oscilloscope probes directly to the capacitor lead.  If 

the capacitor lead is too short to allow all of these connections to it, then use a 

short piece of hook-up wire (less than an inch long) plugged into the 

breadboard next to the capacitor and connect your grounds to that.   

 

 Channel-1 gives the total voltage applied to the circuit.  Measure the 

magnitude of each sinusoid and the phase of VB relative to VA.  Switch the 

channel-2 probe to the capacitor lead as shown above and measure the 

magnitude and phase of VC (relative to VA).   

 

Comment Phasor analysis can be used to treat linear circuits with sinusoidal excitations 

under steady-state conditions.  The phasor voltages VA, VB, and VC all contain 
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both magnitude and phase information.  The current through each element is 

the same, since they are in a series connection, and equal to I = (VA – VB)/ R1.  

Knowing the current phasor, the impedance of the wire and capacitor can be 

calculated as Zwire = (VB – VC)/ I and Zcap = VC / I.    

 

Question-5 Using the data you recorded and the above equations, answer the following:   

 (a)  What is the impedance of the wire?  Is it predominantly inductive, 

resistive, or capacitive?   

 (b)  What is the impedance of the capacitor?  Is it predominantly inductive, 

resistive, or capacitive?   

 (c)  Using a few well-chosen sentences, summarize what you have learned in 

the form of “advice” you would give a friend about how to make a circuit that 

operates at 10 MHz.    
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Procedure 6 Temperature measurement using LabVIEW and DAQ hardware 

 

Comment The goal of this procedure is to get LabVIEW up and running and open an 

existing VI which can be used to measure and log the ambient temperature 

using an LM35DZ integrated circuit temperature sensor.   

 

Set-Up The first step is to set up the data acquisition (DAQ) hardware.  All of the 

these laboratories will utilize the National Instruments NI-USB-6009 DAQ 

which provides 8 single-ended or 4 differential analog inputs with 14-bit 

resolution and up to 48 kS/s sampling, 2 analog outputs with 12-bit resolution 

and up to 150 S/s data rate, a 12-bit multifunction digital I/O block, and a 

built-in 32-bit counter module.  This DAQ is very versatile and completely 

powered through the USB connection.  To connect the DAQ to the computer, 

simply use a standard USB cable to any USB 2.0 port on the computer.  Once 

connected, the DAQ will be recognized by the computer, and if a driver has 

not already been installed, the Windows operating system will automatically 

install the driver for it.  Connect the NI-USB-6009 DAQ to the computer 

using a standard USB cable if it is not already connected.   

 

 Inputs and outputs to the DAQ are from 16 screw terminals on each side of the 

DAQ.  The most convenient method for using the NI-USB-6009 in these 

laboratories is to use a solderless breadboard, also known as “superstrip”, and 

make connections to the DAQ using some solid wire jumpers, as shown below 

in Fig. E0.6a.  The best wires to use are 8 inch long, solid, #22 gauge, with 

different insulation colors to distinguish the different pins, as also shown in 

the figure.  This system then allows subcircuits to be easily constructed on the 

superstrip and allows the DAQ to easily connect to any tie points on the 

superstrip for signal acquisition or injection.   

 

Figure E0.6a  
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 The ambient temperature is measured by an LM35DZ temperature sensor 

which is a small 3-lead part in a TO-92 case.  A DC voltage of 4~20 Volts is 

supplied between the VS and GND pins, and the device will output a DC 

voltage between the VOUT and GND pins which is proportional to the 

ambient temperature in degrees Celsius.  The conversion factor for the 

LM35DZ is 100 mV/C, and it is calibrated so that 0C will produce 0.0 Volts 

output.  Looking at the LM35DZ with its labeled flat side facing you and its 

leads pointing downward, the pin on the left is VS, the pin in the middle is 

VOUT, and the pin on the right is GND.  A +5 Volt DC power supply can be 

obtained from the NI-USB-6009 DAQ itself, using the +5V terminal, pin #31, 

and the digital ground terminal GND, pin #32.  These two leads can be used to 

power up the LM35DZ temperature sensor.  For a stable output, the LM35DZ 

should have a 200 Ω load resistor connected between the VOUT and GND 

pins.  The output voltage is then taken across this 200 Ω load, as shown in Fig. 

E0.6b below.   

 

Figure E0.6b 
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 As shown below in Figs. E0.6c and E0.6d, use a superstrip and some solid 

insulated wire jumpers to connect an LM35DZ temperature sensor to the NI-

USB-6009 DAQ.  Connect a wire from analog input 0 (ai0, pin 2) on the NI-

USB-6009 DAQ to VOUT lead (center) of the LM35DZ, shown in yellow in 

the figures below.  Connect a wire from ground (GND, pin 32) on the NI-

USB-6009 DAQ to GND lead of the LM35DZ, shown in black in the figures.  

Connect a wire from the +5.0 Volt power supply (+5V, pin 31) on the NI-

USB-6009 DAQ to VS lead of the LM35DZ, shown in red in the figures.  

Finally, connect a 200 Ω 1/4 Watt resistor between the VOUT and GND leads 

of the LM35DZ.  The two black screw-terminal blocks on the DAQ should 

have some decals attached which identify the terminals.  If not, see the TA or 

lab manager for some replacement decals.  The terminal blocks can also be 

removed and changed from the DAQ, if needed as well.   
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Figure E0.6c,d     

 

 A very simple and quick method to test that the DAQ card is connected and 

working properly is to use the National Instruments Measurement and 

Automation Explorer (NI-MAX).  From Windows, launch the Measurement 

and Automation Explorer (NI-MAX) from the Start Menu by clicking on Start 

> All Programs > NI-MAX, or alternatively, there may already be a shortcut 

for NI-MAX on the desktop.  After NI-MAX opens, on the left hand side of 

the window is a configuration panel.  Click on the expand button [+] beside 

Devices and Interfaces.  Select the NI USB-6009 DAQ, and the Settings and 

External Calibration should appear in the central panel.  Above the central 

panel, click on a toolbar button called “Self-Test.”  This should return a small 

message window saying that the device has passed its self test.  This indicates 

that the DAQ is properly connected to the computer, that Windows has 

properly recognized the device and has loaded its drivers, and that LabVIEW 

has properly registered the device so that it can be accessed by various VIs that 

call it.  This self-test only tests the DAQ computer connection, not anything 

that may be connected to the DAQ I/O pins.   

 

 If you wish to test the system further, the toolbar button to the right of “Self-

Test” is “Test Panels…” and this provides a more detailed set of commands 

which directly control the DAQ card and can be used to insure that the entire 

system is working properly.  Click on “Test Panels…” and select the Analog 

Input tab.  Make sure that the Channel Name is set to Dev1/ai0 and the Mode 

is set to On Demand.  Change the Max Input Limit to 5 and Min Input Limit 

to 0, and change the Input Configuration to RSE (referenced, single-ended).  

Click on Start, and the chart should show a streaming set of analog 

measurements from the ai0 channel of the DAQ in the range of 0.25 to 0.35 

(Volts).  This validates that the LM35DZ is properly connected to the DAQ 

and that the DAQ is properly sampling the voltage on the center output lead of 

the device.  Click Stop to halt the data streaming and close the Test Panels 

window.   

 

 The National Instruments device driver system allows multiple USB hardware 

devices to be installed simultaneously.  Each are uniquely identified by their 

hardware model number and serial number, and each are given a name which 

allows them to be more conveniently referred to in various VIs.  The present 

name for the NI-USB-6009 appears in the box to the right of “Name” and it 

probably says something like Dev1 or Dev2.  All of the laboratory VIs have 



 Experiment-0 

R. B. Darling EE-331 Laboratory Handbook Page E0.15 

been written for the NI-USB-6009 DAQ as “Dev1.”  If the NI-USB-6009 is 

not listed as “Dev1” you can change this by typing in “Dev1” in the name box 

and clicking on the Save button at the left top of the central panel.  If it 

responds saying that Dev1 is already in use, make the change anyway.  Do this 

now if your DAQ is not already listed as “Dev1.”  If the DAQ has the wrong 

name assigned to it, none of the VIs will properly recognize it.  Once you have 

verified that the DAQ is properly connected and named Dev1, you can EXIT 

MAX at this point.   

 

 The next step is to launch LabVIEW and start up a VI which has already been 

written for making a simple temperature measurement.  From the Windows 

Start Menu, click on Start > All Programs > National Instruments LabVIEW, 

or use the desktop shortcut if it is present.  All of the VIs are written in 

LabVIEW version 13.0, and will run on any version of LabVIEW that is 13.0 

or more recent.  The main LabVIEW window should appear.  Use the Open 

Existing button to navigate to the EE-331 laboratory VIs and select the 

TempSensorReadout.vi.  LabVIEW will first open the front panel window for 

this VI which is from where the virtual instrument is controlled.  If you wish 

to view the internal G-code for this instrument, click on Window > Show 

Block Diagram (or type Ctrl+E).  This is a relatively simple VI, and the block 

diagram shows how the voltage reading from the DAQ card is first multiplied 

by a factor of 100 and then sent to a waveform chart for display.  The 

temperature readings are taken each 500 milliseconds, and a STOP button is 

set up to end the program.  LabVIEW virtual instruments (VIs) always consist 

of two parts:  a front panel and a block diagram.  Ctrl+E switches between the 

two.  Only the front panel needs to be open in order to run the VI.   

 

Measurement-6 To start the temperature measurement VI, make the front panel window active 

by either clicking on it somewhere or select it from the Window menu.  Click 

on the run button, which is shaped like a right-pointing arrow on the toolbar.  

The front panel appearance will change from the grid pattern to a solid pattern, 

and the stop sign will turn to brighter shade of red.  The waveform chart will 

start scanning and you should soon see a signal waveform appear that 

represents the running output of the LM35DZ temperature sensor being 

sampled every 500 milliseconds.   

 

 After the measurement has been running for a few seconds, press your finger 

tip onto the top of the LM35DZ temperature sensor and you should see the 

measured temperature rise by a few degrees Celsius.  After removing your 

finger tip, you should similarly see the measured temperature fall back to close 

to its original value.  Once you have finished running the VI, you can stop it 

by simply clicking on the rectangular STOP button on the front panel.  If for 

some reason this does not work, you can stop the VI by clicking on the red 

stop sign button in the toolbar.  The results of a rising temperature are shown 

in the screen shot of Figure. E0.6e.   
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Figure E0.6e  

 

Comment Generally, it is always best to stop a running VI by using the STOP button that 

is part of the VI front panel.  Using the red stop sign button to stop the VI is a 

more drastic measure which sometimes leaves LabVIEW in a less predictable 

state.  The red stop sign is really a program abort, which should be used as a 

last resort.   

 

Question-6 Explain the time dependent behavior of the measured voltage that you 

observed in the above.  Speculate on what factors determine how fast the 

temperature sensor will react to a change in its case temperature.  Suggest 

some ways of speeding this up, or for slowing it down.   

 

 The waveform chart attempts to display the data from the temperature sensor 

as a “real-time” signal that moves across the display.  From the sampling at 

500 ms intervals, you should notice some corners in the waveform as the chart 

connects the data points by straight lines.  Describe how the sampling rate 

affects (or does not affect) the response time of the temperature measurement 

system.   
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Procedure 7 Adding a Celsius to Fahrenheit conversion 

 

Comment This next procedure will modify the previous VI to add a Celsius to Fahrenheit 

conversion, allowing the measured result to be displayed simultaneously on 

both temperature scales.   

 

Set-up If the previous TempSensorReadout.vi was closed, re-open it.  Open the block 

diagram for this VI by clicking on Window > Show Block Diagram, or typing 

Ctrl+E.   

 

 A sub-VI has already been written which performs the C to F conversion.  

Place this sub-VI inside the while loop by selecting All Functions from the 

Functions pallet and then selecting Select a VI…  Browse to where you find 

the Convert C to F.vi and open this.  With the mouse, click on the block 

diagram to drop the sub-VI into place, somewhere inside the while loop.  

Click on the tools pallet to change the cursor to the wiring tool (this looks like 

a small bobbin) and click on the left side of the Convert C to F sub-VI to 

connect to its input and then drag the wire over to the output from the 100X 

multiplier and click there to make the connection.   

 

 Switch to the front panel window and make it active.  From the Controls 

pallet, select the “Waveform Chart” and drop this into the front panel below 

the existing waveform chart for the Celsius measurement.  You may need to 

resize the front panel window to create enough space to do this.  Position and 

resize the waveform chart to your liking.  You can also copy the first 

waveform chart and paste a copy below it.  Right click on the new waveform 

chart and select Properties.  From the properties window, the scales can be 

adjusted.  Format the vertical scale to read “Fahrenheit” and give it a range of 

50 to 100.  Format the horizontal (time) scale to run from 0 to 10 samples, 

which is equivalent to 5 seconds on the original waveform chart.  Switch back 

to the block diagram window and use the wiring tool to connect the output of 

the C to F sub-VI to the input of the new Waveform Chart.   

 

 Using File > Save As … , save the modified VI with a new name “Experiment 

0 Procedure 7.vi” in your own directory.   

 

Measurement-7 Switch back again to the front panel window.  Click the run button on the 

front panel and observe that both waveform charts show the correct 

temperature behavior.  Click on the STOP button to halt the program.   

 

Question-7 Describe how you would create another VI that would display the temperature 

in degrees Kelvin.  You do not need to write another VI for this unless you 

want to; just describe in general terms how you would go about doing so.   
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Procedure 8 Saving measurement results to spreadsheet files 

 

Comment This next procedure will modify the temperature measurement VI once more 

to add the capability to store the measurement results in a spreadsheet file.   

 

Set-Up Open the VI that you modified and saved in Procedure 7, if it is not open 

already, and open its block diagram window.   

 

 From the Functions pallet, select All Functions > Programming > File I/O > 

Write To Spreadsheet File, and use the mouse to drop this function into the 

block diagram to the right of, and outside of, the while loop.  Change the 

cursor to the wiring tool and click on the output of the Convert C to F sub-VI 

and drag the wire to the right edge of the while loop.  A small box will appear 

at this termination.  Use the wiring tool to click on this small box and extend 

the wire to the 1D Data input of the Write To Spreadsheet File function.  

Right click on the small box to pop up the options, and select “Enable 

Indexing.”  This should make the small box appear with braces ([ ]) inside it.  

The orange wire inside the while loop should be a thin one, indicating a 

simple double precision value, and the orange wire outside the while loop 

should be a thick one, indicating that the output from the while loop is now an 

array of values.  Once the STOP button is pressed, the while loop will end, 

and all of the measurements that have been taken up to this point will then be 

passed to the Write To Spreadsheet File function as one row array of values.  

To put these instead into a single column, wire a True Boolean constant to the 

Transpose terminal of the Write to Spreadsheet File function.   

 

 Using File > Save As … , save the modified VI with a new name “Experiment 

0 Procedure 8.vi” in your own directory.   

 

Measurement-8 Make the front panel window for the new modified VI active and click on the 

run button to start its operation.  The Celsius and Fahrenheit waveform charts 

should both begin displaying the running temperature data.  After a few 

minutes, click on the STOP button.  A Save As … dialog window will open in 

which you can specify the location to where the new Excel (.xls) file will be 

written.  Enter a new file name, such as “Experiment0Procedure8.xls” and 

click on “OK.”  After the file has been written, use Excel to open this file and 

verify that the correct data values have been written there in the first column 

of the worksheet.  You might also create a plot within Excel and compare this 

to what you saw displayed on the waveform chart for the Fahrenheit 

temperatures.   

 

Question-8 If the new VI is kept running for 5 minutes, how many Fahrenheit temperature 

readings will be stored in the spreadsheet file?   

 

 


